navitron
 
Renewable Energy and Sustainability Forum
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Anyone wishing to register as a new member on the forum is strongly recommended to use a "proper" email address - following recent spam/hack attempts on the forum, all security is set to "high", and "disposable" email addresses like Gmail, Yahoo and Hotmail tend to be viewed with suspicion, and the application rejected if there is any doubt whatsoever
 
Recent Articles: Navitron Partners With Solax to Help Create A More Sustainable Future | Navitron Calls for Increased Carbon Footprint Reduction In Light of Earth Overshoot Day | A plea from The David School - Issue 18
   Home   Help Search Login Register  
Pages: 1 [2]   Go Down
  Print  
Author Topic: Think I've killed my batteries...  (Read 3968 times)
daserra
Sr. Member
****
Offline Offline

Posts: 291



« Reply #15 on: January 09, 2014, 01:10:20 AM »

I've had the electrolyte evaporate out of batteries before; an expensive mistake.
Logged

Rammed earth/ytong PassivFrankenHaus.
In the hills in Southern Portugal.
Borehole, on-grid.
Home made pool solar.
jules27
Newbie
*
Offline Offline

Posts: 29


« Reply #16 on: May 04, 2014, 07:18:28 PM »

I bought some charged batteries and let them sit for 18months or more! When I finally got round to connecting them up(don't ask) ,they were dead as a dodo. So took them back to the shop they charged them ( a few times!! ) and they are fine -not quite as good as new but they hold a charge ok .So your batts may be recoverable.
Logged

10 x 100w Canadian Solar Panels ,1 x C60 Xantrex controller & BTS, 1 x Studer C2600 24v , 4 x 6V Rolls 453ah batteries . 1 x Lorentz surface pump ps150 , 2 x 40w kyocera panels KC40 , cheap charge controller and 60ah battery .
Pages: 1 [2]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines
SMFAds for Free Forums
Simple Audio Video Embedder
Valid XHTML 1.0! Valid CSS!